User Tools

Site Tools


xorg.conf

Mon xorg.conf ATI qui fonctionne en dualhead !!! avec les drivers radeon Libre !!! J'obtiens 6700FPS avec glxgears sur mes deux écrans.

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************
                                
Section "InputDevice"           
                                
    Identifier  "Keyboard1"     
    Driver      "kbd"           
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"  
    Option "XkbModel"   "pc105" 
    Option "XkbLayout"  "fr"    
                                
EndSection                      
                                
                                
# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
                                
Section "InputDevice"           
# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "ExplorerPS/2" # Explorer PS/2
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"   "4 5 6 7"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
    Identifier  "samsung"
    Option "DPMS"
EndSection

Section "Monitor"
        Identifier  "acer"
        Option "DPMS"
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
        Identifier      "ati0"
        Driver          "radeon"
        Option "GartSize" "64"
        Option "EnablePageFlip"
        Option "ColorTiling"
        Option "AccelMethod" "on"
        BusID           "PCI:5:0:0"
        Screen          0
EndSection


Section "Device"
        Identifier      "ati1"
        Driver          "radeon"
        BusID           "PCI:5:0:1"
        Screen          1
EndSection



# **********************************************************************
# Screen sections
# **********************************************************************

Section "Screen"
        Identifier "Screen 0"
        Device "ati0"
        Monitor "acer"
        DefaultDepth 24
                     SubSection "Display"
                     Depth 24
                     Virtual 3360 1050
                     EndSubSection
EndSection

Section "Screen"
        Identifier "Screen 1"
        Device "ati1"
        Monitor "samsung"
        DefaultDepth 24
                     SubSection "Display"
                     Depth 24
                     Virtual 3360 1050
                     EndSubSection
EndSection


#Section "ServerLayout"
#        Identifier      "singlehead"
#        Screen          "Screen 0"
#        InputDevice "Mouse1" "CorePointer"
#        InputDevice "Keyboard1" "CoreKeyboard"
#EndSection

Section "ServerLayout"
        Identifier      "DualHead Layout"
        Screen          0 "Screen 0" 0 0
        Screen          1 "Screen 1" LeftOf "Screen 0"
        
        InputDevice "Mouse1" "CorePointer"
        InputDevice "Keyboard1" "CoreKeyboard"

        #InputDevice    "Generic Keyboard"
        #InputDevice    "Configured Mouse"
        #InputDevice    "Synaptics Touchpad"
EndSection


Section "Dri"
    Group "video"
    Mode 0666
EndSection

Vous remarquerez que je n'ai pas d'entrée xinerama dans ma section ServerLayout, en effet le dualhead avec xinerama activé dans xorg.conf et le module libre ati, ça ne fonctionne pas. Il va falloir seter le dualscreen avec notre ami xrandr

Il faut seter l'opengl sur xorg-x11

eselect opengl set xorg-x11

Puis il faut la commande xrandr qui va bien, car xinerama ne fonctionne pas avec les drivers ati libre. (la fonction clone fonctionne par contre).

Ha grosse subtilité !

echo "x11-drivers/xf86-video-ati" >> /etc/portage/package.keywords
echo "x11-drivers/xf86-video-ati dri" >> /etc/portage/package.use
emerge -av x11-drivers/xf86-video-ati dri

Il faut la dernière version du drivers ati afin de faire fonctionner le dualhead ( la version 6.9 ). Sinon si vous n'avez pas besoin du dualscreen vous pouvez trés bien utiliser la version stable.

Il faut recompiler xorg-xserver avec le flag dri. Je conseil d'inclure le flag dri directement dans son /etc/make.conf (sous gentoo). dans le make.conf il faut biensur rajouter le falg radeon à l'entrée

VIDEO_CARDS="vesa radeon"

pour la commande xrandr qui va bien une fois que votre setup fonctionne en dualscreen (mode clone):

xrandr -q
xrandr --output DVI-1 --right-of DVI-0

Et voilà vous êtes en dualscreen avec les drivers ATI libre sans xinerama, mais votre X réagira comme si il avait xinerama d'activé !

Quelle satisfaction d'être enfin totalement libre.

J'ai une carte Nvidia à refourguer maintenant …. :)

xorg.conf.txt · Last modified: 2018/06/18 11:07 (external edit)